Read Gentoo Forums :: Voir le sujet - Emerge Portage - required EAPI 1 text version

Recherche rapide:

dans

Tous disponible

FAQ | Rechercher | Liste des Membres | Groupes d'utilisateurs | Statistiques | Profil | Se connecter pour vérifier ses messages privés | Connexion | S'enregistrer

Emerge Portage - required EAPI 1

Gentoo Forums Index du Forum

Voir les messages sans réponses Voir les messages des dernières 24 heures

Portage & Programming Voir le sujet précédent :: Voir le sujet suivant

Auteur TheCykor

n00b Posté le: Ven Mar 20, 2009 4:02 am required EAPI 1

Message

Sujet du message: Emerge Portage -

Hi all!

Inscrit le: 16 Fév 2004 Messages: 8

I had some very stable Gentoo System and did some time no upgrade, i executed now some synch and want to upgrade portage (or anything else) and get the following output:

Code: bash-3.2# emerge portage !!! Your current profile is deprecated and not supported anymore. !!! Please upgrade to the following profile if possible: default/linux/x86/2008.0/server To upgrade do the following steps: # cd /etc/ # rm make.profile # ln -s ../usr/portage/profiles/default/linux/x86/2008.0/server make.profile

Calculating dependencies / !!! All ebuilds that could satisfy ">=dev-lang/python-2.5" have been masked. !!! One of the following masked packages is required to complete your request: - dev-lang/python-2.5.4-r2 (masked by: required EAPI 1, supported EAPI 0) - dev-lang/python-2.5.2-r7 (masked by: required EAPI 1, supported EAPI 0) - dev-lang/python-2.5.2-r8 (masked by: required EAPI 1, supported EAPI 0) - dev-lang/python-2.6-r5 (masked by: required EAPI 2, supported EAPI 0) # Ali Polatel <[email protected]> (05 Oct 2008) # Masked until packages that don't work with it are fixed. # see bug #230205 for more info - dev-lang/python-2.6.1 (masked by: required EAPI 2, supported EAPI 0)

For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. (dependency required by "dev-python/pycrypto-2.0.1-r8" [ebuild])

As far i researched Python needs newer version of portage and portage needs newer version of Python --> deathlock?? Also unmasks did not work for EAPI Do you have any ideas? Upgrading the profile as suggested is not working (2008 directory is not there). Originaly link from make.profile was to 2008 so some error message was displayed and i manually corrected it to 2007 directory which is the most recent existing dir. Thanks in Advance! Gabriel[/code]

Code: bash-3.2# emerge --info !!! Your current profile is deprecated and not supported anymore. !!! Please upgrade to the following profile if possible: default/linux/x86/2008.0/server To upgrade do the following steps: # cd /etc/ # rm make.profile # ln -s ../usr/portage/profiles/default/linux/x86/2008.0/server make.profile

Portage 2.1.2.2 (default-linux/x86/2007.0/server, gcc-3.3.5­20050130, glibc-2.3.4.20041102-r1, 2.6.14-gentoo-r5 i686) ================================================================= System uname: 2.6.14-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz Gentoo Base System release 1.12.9 Timestamp of tree: Fri, 20 Mar 2009 01:45:01 +0000 app-shells/bash: 3.2_p15-r1 dev-java/java-config: 1.3.7, 2.0.32 dev-lang/python: 2.3.5-r2, 2.4.3-r1 dev-python/pycrypto: 2.0.1-r5 sys-apps/baselayout: 1.12.9-r2 sys-apps/sandbox: 1.2.17 sys-devel/autoconf: 2.13, 2.61 sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10 sys-devel/binutils: 2.16.1-r3 sys-devel/gcc-config: 1.3.12-r4 sys-devel/libtool: 1.5.18-r1 virtual/os-headers: 2.6.11-r2 ACCEPT_KEYWORDS="x86" CBUILD="i686-pc-linux-gnu" CFLAGS="-O2 -march=pentium4 -pipe" CHOST="i686-pc-linux-gnu" CONFIG_PROTECT="/etc /usr/lib/X11/xkb /var/bind" CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"

CXXFLAGS="-O2 -march=pentium4 -pipe" DISTDIR="/usr/portage/distfiles" FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict" GENTOO_MIRRORS="http://gentoo.inode.at/ http://ftp.belnet.be /mirror/rsync.gentoo.org/gentoo/ http://linux.rz.ruhruni-bochum.de/download/gentoo-mirror/" MAKEOPTS="-j2" PKGDIR="/usr/portage/packages" PORTAGE_CONFIGROOT="/" PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*" PORTAGE_TMPDIR="/var/tmp" PORTDIR="/usr/portage" SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage" USE="PEAR X acl apache apache2 bacula-console bacula-split-init bcmath berkdb cgi chroot cli cracklib crypt cups curl dri dvd exif fortran gd gdbm gpm iconv isdnlog ldap mailwrapper management midi mudflap mysql ncurses nls nptl nptlonly odbc openmp pam pcre perl php postgres pppd python readline reflection samba session snmp spl ssl tcpd threads truetype ttf unicode x86 xfs xml xmlreader xmlrpc xmlwriter xorg xpm yaz zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt intel mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo" Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY Revenir en haut de page purak

Tux's lil' helper Posté le: Ven Mar 20, 2009 4:22 am Sujet du message:

Portage tells everything to you

Code:

Inscrit le: 21 Juin 2008 Messages: 141 Localisation: /dev/urandom

!!! Your current profile is deprecated and not supported anymore. !!! Please upgrade to the following profile if possible: default/linux/x86/2008.0/server

I think, you must chance your system profile.

Code: eselect profile list

it looks like the following..

Code:

Available profile symlink targets: [1] default/linux/x86/2008.0 * [2] default/linux/x86/2008.0/desktop [3] default/linux/x86/2008.0/developer [4] default/linux/x86/2008.0/server [5] hardened/x86/2.6 [6] selinux/2007.0/x86 [7] selinux/2007.0/x86/hardened [8] hardened/linux/x86

You select one of them. For example

Code: eselect profile set 1

After that, you had better use this command for system upgrade

Code: emerge -DNvA world

maybe works sorry for english _________________

Revenir en haut de page TheCykor

n00b Posté le: Ven Mar 20, 2009 4:29 am Sujet du message:

Inscrit le: 16 Fév 2004 Messages: 8

Thanks for the answer, profile thing could be solved, but still have the same problems. Also I am no native speaker so I reckognized nothing *g* Any other Ideas?

Code: roxor ~ # emerge -DNvA world usage: emerge [options] emerge: error: no such option: -A roxor ~ # emerge -DNv world These are the packages that would be merged, in order: Calculating world dependencies \ !!! All ebuilds that could satisfy ">=dev-lang/python-2.5" have been masked. !!! One of the following masked packages is required to complete your request: - dev-lang/python-2.5.4-r2 (masked by: required EAPI 1, supported EAPI 0) - dev-lang/python-2.5.2-r7 (masked by: required EAPI 1, supported EAPI 0) - dev-lang/python-2.5.2-r8 (masked by: required EAPI 1, supported EAPI 0) - dev-lang/python-2.6-r5 (masked by: required EAPI 2, supported EAPI 0) # Ali Polatel <[email protected]> (05 Oct 2008) # Masked until packages that don't work with it are fixed. # see bug #230205 for more info

- dev-lang/python-2.6.1 (masked by: required EAPI 2, supported EAPI 0) For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. (dependency required by "dev-python/pycrypto-2.0.1-r8" [ebuild])

!!! Problem resolving dependencies for mail-client/pine !!! Depgraph creation failed. Revenir en haut de page sera

l33t Posté le: Ven Mar 20, 2009 4:54 am Sujet du message:

Inscrit le: 29 Fév 2008 Messages: 741 Localisation: CEST

You have python 2.4.3-r1 installed witch is enough for the current stable portage. As you have also a 2.3 version installed you might have forgotten to run python-updater. As portage is EAPI="0" you should fulfill the requirements. Always update portage first. And -A should be -a and add an -u for --update to the list of options.

Revenir en haut de page Dark Foo

Guru Posté le: Ven Mar 20, 2009 5:33 am Sujet du message:

Inscrit le: 21 Nov 2008 Messages: 440 Localisation: /dev/null

emerge portage emerge -auDNv system emerge -auDNv world _________________ =========== Cogito ergo sum ===========

Revenir en haut de page AllenJB

Veteran Posté le: Ven Mar 20, 2009 6:30 am Sujet du message:

purak a écrit: Portage tells everything to you Code:

Inscrit le: 02 Sep 2005 Messages: 1244 Localisation: Ashford, Kent

!!! Your current profile is deprecated and not supported anymore. !!! Please upgrade to the following profile if possible: default/linux/x86/2008.0/server

I think, you must chance your system profile.

Changing the profile will not fix the problem. In fact it could well leave you in a worse situation. Fix the EAPI problem first, since that's what's blocking the portage upgrade.

I would recommend you update your base system at least once every 6 months (a year at the most). I would suggest that your only chance is to upgrade to an intermediate version of portage, then upgrade python, then upgrade portage to the latest stable version. You may also want to search the forums as there have been a number of people trying to upgrade insanely old setups like yours recently and one of them may have posted a solution. I would heavily recommend you backup first, in case you completely hose your install (instructions given on the forums are often incorrect, as illustrated already by those above). You may well find that the simplest and quickest solution is to reinstall from scratch. Related thread: http://forums.gentoo.org/viewtopic-t-747824.html _________________ http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs

Dernière édition par AllenJB le Ven Mar 20, 2009 6:50 am; édité 1 fois

Revenir en haut de page d2_racing

Moderator Posté le: Ven Mar 20, 2009 6:41 am Sujet du message:

Maybe the best for you is to run this : Upgrade your profile to 2008.0 and then run this :

Code:

Inscrit le: 25 Avr 2005 Messages: 12374 Localisation: Ste-Foy,Canada

# emerge -aev system # emerge -aev world

This will recompile your box from A to Z. Don't forget to recompile your kernel when you finish your recompilation. _________________ Sysadmin of Gentoo-Québec.org Wiki Signature IRC on Freenode : #gentoo-quebec

Revenir en haut de page AllenJB

Veteran Posté le: Ven Mar 20, 2009 6:51 am Sujet du message:

d2_racing a écrit: Maybe the best for you is to run this : Upgrade your profile to 2008.0 and then run this :

Inscrit le: 02 Sep 2005 Messages: 1244 Localisation: Ashford, Kent

Code: # emerge -aev system # emerge -aev world

This will recompile your box from A to Z. Don't forget to recompile your kernel when you finish your recompilation.

Ignoring the fact that upgrading the profile could easily do more harm than good and that the emerge will bail out on exactly the same message when it considers upgrading portage, this will fail miserably because virtually the entire tree is now EAPI=1 or EAPI=2. _________________ http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs

Revenir en haut de page TheCykor

n00b Posté le: Ven Mar 20, 2009 7:01 am Sujet du message:

Hi all!

Inscrit le: 16 Fév 2004 Messages: 8

I found http://forums.gentoo.org/viewtopic-t-747824-highlight-eapi.html now Following thing seemed to work: emerge --nodep portage emerge --nodep python emerge portage emerge python

Portage and Python are up to date now and i am start checking all other things now and hope that this issue could be solved Best regards Gabriel

Revenir en haut de page

Montrer les messages depuis: Tous les messages

Le plus ancien en premier

Aller

Gentoo Forums Index du Forum Programming Page 1 sur 1

Portage & Toutes les heures sont au format GMT - 5 Heures

Sauter vers: Portage & Programming Vous ne pouvez pas poster de nouveaux sujets dans Vous ne pouvez pas répondre aux sujets dans Vous ne pouvez pas éditer vos messages dans Vous ne pouvez pas supprimer vos messages dans Vous ne pouvez pas voter dans les sondages de

Aller

ce ce ce ce ce forum forum forum forum forum

Liens: forums.gentoo.org | www.gentoo.org | bugs.gentoo.org | [email protected]

Copyright 2001-2010 Gentoo Foundation, Inc. Designed by Kyle Manna © 2003; Style derived from original subSilver theme. | Hosting by Gossamer Threads Inc. © | Powered by phpBB 2.0.23-gentoo-p2 © 2001, 2002 phpBB Group

Information

Gentoo Forums :: Voir le sujet - Emerge Portage - required EAPI 1

8 pages

Report File (DMCA)

Our content is added by our users. We aim to remove reported files within 1 working day. Please use this link to notify us:

Report this file as copyright or inappropriate

1286312


You might also be interested in

BETA
Gentoo Forums :: Voir le sujet - Emerge Portage - required EAPI 1